Acura Legend Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
This site is pretty cool. Im glad I found it..
My question is this. When I'm driving I get this loud noise from my front driver side wheel. This sound(sqeaking) gets louder as I drive and stops when I apply the brakes. I took off from work today to get my front brakes looked at. And of course the noise went away. Possibly because of the rain...who knows! Anyway, the shop told me my front brakes were 90% good, rear 40% and looked good. Could this loud noise of what sound like metal rubbing have anything to do with the wheel bearings??? What do you guys think..Has anyone had this problem! I was thinking the pads and or rotors were glazed but the shop said that they didnt think so....
 

·
Registered
Joined
·
33 Posts
My car was making a dragging noise and it was squeaking. I had just had my brakes replaced. I took it to the shop and they told me it was the hub and the wheel bearings. Later, they told me the rotors were bad and needed to be cut. Cost me $400 but thats because my breaks were replaced and stuff. If you do get it done make sure they give you a lifetime warranty. Hope every thing goes well.. ;)
 

·
Registered
Joined
·
3,199 Posts
My brakes were fixed when I put on OEM pads... I had this grotesque squel that would also go away with the brake pads applied, and it turned out that it was the front brakes, and I replaced with acura parts... fixed it for sure.

Might be your case as well;)
 
1 - 3 of 3 Posts
Top