Acura Legend Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,113 Posts
Discussion Starter · #1 ·
i posted a tread a while ago about my car not starting sometimes. i thought it was because of my stereo system but i dont think that is the problem.. here is what my car is doin.. when i turn the key all the lights come on (engine, battery, oil ect.) once they go off the car starts but sometimes my engine light will stay on and thats when the car wont start.. any ideas??
 

·
Registered
Joined
·
1,113 Posts
Discussion Starter · #2 ·
one more thing.. if i bang on the dash near the latch to pop the hood the light goes off and the car will start(ghetto but it works) dont think i sit there bangin on my car because it wont start lol i found that out one day while the light was on i went to go look under the hood and wen i pulled the latch the light went on...
 

·
Registered
Joined
·
3,795 Posts
When you turn your key and it doesn't start, turn you radio off/down. Listen to see if you hear a humm coming from the fuel pump. If you don't hear a humm then there is a good chance that your main relay needs to be replaced or re-soldered. Do a search on main relay for more info.
 

·
Registered
Joined
·
1,113 Posts
Discussion Starter · #5 ·
When you turn your key and it doesn't start, turn you radio off/down. Listen to see if you hear a humm coming from the fuel pump. If you don't hear a humm then there is a good chance that your main relay needs to be replaced or re-soldered. Do a search on main relay for more info.
aight thanks.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top