Acura Legend Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
3,292 Posts
Discussion Starter · #1 ·
And my MLS strut bar is here. Let me tell you it makes a noticeable difference.To the guys who already have it do you have problems with the hood not wanting to shut all the way? I mean it shuts but my hood isnt sitting flush against the fender:confused:
 

·
Junior Mint
Joined
·
629 Posts
No problems with fitment.


Was this from the Dale groubuy?
 

·
Registered
Joined
·
847 Posts
same as EK
 

·
Registered
Joined
·
3,292 Posts
Discussion Starter · #4 ·
No i went thru another source. My hood sticks up now. Man im pissed.


Well at least the bar works.:)
 

·
Registered
Joined
·
3,292 Posts
Discussion Starter · #6 ·
No i lost my uploading software for my camera . I can explain it to you though
 

·
GS Hog
Joined
·
7,026 Posts
Yeah, if you could, maybe we can figure if something went wrong somewhere (though I can't think of what right now).
 

·
Registered
Joined
·
3,292 Posts
Discussion Starter · #11 ·
Basically I took of on each side 2 bolts. I then had to work on the bar onto the suds. from there I just bolted down the bar. It is poking holes into my ood liner and my hood I have to put xtra effort to close it.
 

·
GS Hog
Joined
·
7,026 Posts
Does it look like this? The mounting studs should include the one closest to the engine, and the one closest to the firewall (actually, as I remember it, the strut bar should only go on one way anyway).

 

·
Registered
Joined
·
57 Posts
Blo said:
And my MLS strut bar is here. Let me tell you it makes a noticeable difference.To the guys who already have it do you have problems with the hood not wanting to shut all the way? I mean it shuts but my hood isnt sitting flush against the fender:confused:
what did you pay for the strut bar? did you get it ordered from JP?
does the bar push on the hood when you do sharp turns?
 

·
Registered
Joined
·
3,292 Posts
Discussion Starter · #14 ·
LegendGS said:
Does it look like this? The mounting studs should include the one closest to the engine, and the one closest to the firewall (actually, as I remember it, the strut bar should only go on one way anyway).

Yeah just like that. Did you have to play with it to get it to fit? I did.

what did you pay for the strut bar? did you get it ordered from JP?
I went thru another source and yes I did get it from Japan. I paid about 225 and had to wait 3 months(only because other parts he ordered were backordered)
 

·
Junior Mint
Joined
·
629 Posts
225 is a great price, can you tell us your source?

Make sure it's the strut bar for the Legend. Maybe there's a mistake there.
 

·
Registered
Joined
·
3,292 Posts
Discussion Starter · #17 ·
I will post source later tonight. I ave to go to school.
IT is for the KA7.
 

·
Yaozer *n *he A*k
Joined
·
310 Posts
Do the struts themselves have to be removed to install the strut bars, or is it just the bolt that your undo? Is there anymore groupbuy going on for these?
 

·
Registered
Joined
·
3,292 Posts
Discussion Starter · #19 ·
rockshox72 said:
Do the struts themselves have to be removed to install the strut bars, or is it just the bolt that your undo? Is there anymore groupbuy going on for these?
Upi just remove 2 bolts on each side. Ask LegendGS about the gb. I believe its over. I will get the email for my source when I get back from a meeting.

Anyone know why my hood still sticks up? Any thoughts
 

·
0000$$$$0000####0000
Joined
·
4,926 Posts
Have you figured out the problem? I'm having the same problem as you are with the copy MLS strut bar on my Coupe. Also, is your car a Coupe or Sedan? It seems like the Sedan guys are not having any problems, although I can't see any differences under the hood, so it could just be coincidence
 
1 - 20 of 25 Posts
Top