Acura Legend Forum banner

Vehicle Speed Sensor Replaced, still not working, ideas?

1002 Views 2 Replies 2 Participants Last post by  Markus
I have a 2004 RL.(140k miles) Last week my D4 started flashing, My VSA light and check engine light came on.The speedometer showed no speed. My OBDII reader read a P0501 code," Vehicle Speed Sensor A circuit range/performance." My Foxwell analyzer showed no signal from the VSS unit while driving. I ordered and replaced the part with a Standard motors VSS exact replacement for what was on the car and had worked great. (cost about $150 thru Rockauto, Dealer has discontinued this part). However, this did not fix the problem, same symptoms as before. Any ideas.
1 - 3 of 3 Posts
It Could be a problem in the wiring, the replacement part could be defective, or the ecu is bad. Any sensors needs to be replaced with the Honda OEM equipment and I think the price is the same for this particular part.
I followed the procedure to measure the voltage of the wires feeding the VSS, in particular the blue-white one which is supposed to alternate between 0 and 5 volts as the tire turns. I was able to see a great variation in the voltage of the wire just by shaking the wires! There were no big obvious insulation breaks but upon examination, there were small cracks in the insulation. I ran a new blue-white wire which reduced the problem somewhat but not totally. Finally, I separated all the wires coming down to feed the VSS as well as the temp sensor and wrapped them individually in harness tape. I found more micro cracks in the insulation, That made the voltage reading stable. It has worked ever since.
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.