Acura Legend Forum banner
1 - 7 of 7 Posts

·
Blk/BlkGS6
Joined
·
1,753 Posts
also kinda related topic but my small antenna receiver unit for my keyless entry and security system was attached to the top of the inside of my windshield with the adhesive sticker it came with, its only been a month or so but it keeps falling off now, what should i use to stick it back up there?? also the brain unit of my alarm system which is under the drivers side dash fell down and i just stuck it back up there..............what should i do for that?? dang this what u get for a cheap install job......lol
 

·
Registered
Joined
·
851 Posts
As long as it has flat surfaces, it will hold it. Even just a very small flat surfaces, the 3M tape will be able to hold it very nicely. The alarm brain too. You will have no problem of falling after you used it. Try to buy them at your local bodyhop supplies, or walwart. But walmart just sell in very small package, and if you need a lot, it will be very expensive.
 

·
Registered
Joined
·
4,106 Posts
Using the 3M moulding tape to retape an emblem, esp a series of letters, is an exercise in futility. It is extremely difficult to cut the adhesive w/o some of it showing around the edges. You often have to use two strips of moulding tape and anywhere there are gaps, there is a tendency over time for dirt to infiltrate and cause the emblem to separate from the tape. The correct procedure is to have used a release agent on the original emblem so as to not damage the backing. Then use clear emblem adhesive to reglue. This glue, however, will damage paint. The short response is to just buy a new emblem.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #6 ·
LPB said:
Using the 3M moulding tape to retape an emblem, esp a series of letters, is an exercise in futility. It is extremely difficult to cut the adhesive w/o some of it showing around the edges. You often have to use two strips of moulding tape and anywhere there are gaps, there is a tendency over time for dirt to infiltrate and cause the emblem to separate from the tape. The correct procedure is to have used a release agent on the original emblem so as to not damage the backing. Then use clear emblem adhesive to reglue. This glue, however, will damage paint. The short response is to just buy a new emblem.
LPB,

Can the clear emblem adhesive be used to glue back on emblems with no backing? Also who makes the clear adhesive and where can I buy it? Thanks.
 

·
Registered
Joined
·
851 Posts
I don't know why you said it is not a good idea or what using the 3M double sided tape. But, I have good results with it. You must remove your old adhesive from the emblems of course, and put the 3M after that. I never experience any difficulties whatever. But oh well, different people has different opinion I guess.

But, if you don't want to damage your paint, the 3M is the way to go.

LPB said:
Using the 3M moulding tape to retape an emblem, esp a series of letters, is an exercise in futility. It is extremely difficult to cut the adhesive w/o some of it showing around the edges. You often have to use two strips of moulding tape and anywhere there are gaps, there is a tendency over time for dirt to infiltrate and cause the emblem to separate from the tape. The correct procedure is to have used a release agent on the original emblem so as to not damage the backing. Then use clear emblem adhesive to reglue. This glue, however, will damage paint. The short response is to just buy a new emblem.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top