Acura Legend Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
495 Posts
Discussion Starter · #1 ·
I think i broke one of the ABS wheel Speed sensors near the spring on the front of the car. My abs and traction control light is on all the time. And neither ABS brakes or traction control works now. Do you think that is what it is??? If soo how much is the sensor and how hard is it to install??? Thanks alot, Nate
 

· Registered
Joined
·
4,086 Posts
The ABS sensor is used for ABS and traction control. Both will not work.

My friend was having those issues as well as decreased engine performance while cornering(accelerating).

AoA the sensor with cost $125 i think...or 160.

Will be some what easy to install. check if you broke the bolts holding it.
 

· Registered
Joined
·
4,119 Posts
Why ask for "guesstimates" when the system has a self-diagnostic function and it will tell you exactly what is wrong. Either "tap" the computer yourself, or take the vehicle to Acura for an ALB function test. The test will take about 45 min or less. Then you will know exactly what needs to be repaired.
 

· Banned
Joined
·
14,938 Posts
i have the same problem with my car, my tcs and abs light come on, i had it diagnoised and i was told its the rear driver side abs sensor, (so have it checked out and they will tell you which one it is) and they run about 50-100 used and must be removed carefully because they tend to break when removed and it better to remove it from your hub when it is worm (or let the hub get to at least room temp) because it is a very very tight fit, when its hot metal expands and the sensor come out and goes in easier.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top