Acura Legend Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi
New to this forum. :)
Recently bought an Acura Legend 1989 L with 145k. It runs great. These days i hear a whining noise when the engine starts and gradually settles down. Also i get a burning smell, something like some insulation burning. I need some advice if it is the power steering fluid. I have bad experiences going to the repair shops. Some of them dont have any knowledge. So i want to know what it is. If anyone has the same problem, please let me know ..
Thanks,
 

· because i can.
Joined
·
10,426 Posts
Hey welcome to the forums man!

Well for the noise...is it coming from the passenger or drivers side?

if passenger's side, check belts and idler...

if drivers side, take off the distributor cap and tell us if you see redish colored dust inside the cap...if so, your bearing on the dizzy is going out and you'll need a new one (distributor assembly that is)...

if its not that (and the caps nice and clean inside), and if you have a 5 speed, while the car is actually making the whining noise, push your clutch in...if it stops making the noise altogether or it decreases in volume, your TO bearing is on its way out...also assuming that you have a 5 speed, if your TO bearing is on its way out, that could indicate a worn clutch assembly altogether and would DEFINITELY be connected with the burning smell if you run the clutch hard or if it slips a lot...

OF COURSE the smell COULD BE oil leaking from side covers and onto the exhaust manifold...

These are all just initial guesses dude so tell me if I have a hit or miss! Also give us some details (engine condition, millage, oil leaking? Tranny, etc.) and some pics of your car when you get a chance! :D

And again welcome to the forums!! If you like the Legend then you will like it here very much as well!!
 

· Registered
Joined
·
638 Posts
if it does it while idling get under that hood and pinpoint where it is, you can use a long wrench, extention, or whatever like a stethiscope to find out if its comming from inside the distributor or whatever.

im guessing its a drive belt, when its cold it slips and makes a burning smell, but once it warms up it gets some traction and stops. when belts get old and hard they can slip, so if thats the case spray some belt dressing on it and replace it soon as you get a chance.

Lucky for us our legends have a drive belt for each device so if one breaks it doesnt take the rest with it. worst outcome is that the battery dies from no charging
 

· Registered
Joined
·
4,259 Posts
acura_kin said:
need some advice if it is the power steering fluid.
Noise can also happen due to lack of fluid in the power steering reservoir, this will cause a whine under load, check if you have a leak... burnt smell could just be power steering fluid.
 

· Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
thank you all for the replies. I observe that the noise is comming from the passenger side. The distributor is good . May be i have to check for the belts. was busy with school stuff trying to finish off this semester. Will come back soon with the info provided in this forum.
Thank you all ..
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top