Acura Legend Forum banner
1 - 10 of 10 Posts

· Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
hi i am new to this forum... i have a 94 acura legend my windshield wiper stop working .when i turn the wipers on i can hear the motor running .not sure if it needs to be replaced any ideas?..if it needs to be replace how much est cost?...thanks
 

· Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
windshield motor

thanks for the info on the windshild motor...is their any special tool that i need to remove the bad caps since the arms would not move? also is this something i can do myself i use to be a machinist so i am mechanically incline thanks..
 

· Registered
Joined
·
264 Posts
It is a no brainer. Anyone can do this. You will not damage anything. The caps are shaped like a hemisphere and snap in to hold the wiper arms in place.
Lack of grease pushes the cap off after a decade. When mine fell off I glued it and applied lots of auto grease.
 

· Registered
Joined
·
2,144 Posts
check to see if the nut that connects the wiper arm to the motor is tight. i had this same problem, and it ended up being just a loose nut. just look at the base of teh wiper arm until you see a nut on the exterior (facing the sky) and make sure that it's tight.
 

· Registered
Joined
·
185 Posts
same prob

I had the same prob.... I opend the area where the motor assembly is and guess what... The bushing that snaps onto the motor arm fell off the motor and the

second arm also fell off its connection to the driver side wiper. I poped them back together untill they go again or I have time to change them as I ordered

the arms that same day... about 50 bucks for both
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top