The Acura Legend & Acura RL Forum - View Single Post - My car feels like a boat at highway speeds - suspension help needed...
Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
View Single Post
Old 11-02-07, 12:11 AM   #13 (permalink)
AllCammedUp
Registered User
 
AllCammedUp's Avatar
 
Join Date: Oct 2006
Location: Shelbyville, KY
Posts: 321


Car 1: 1991 LS Sedan


I will install the copy bar this weekend to see what the difference is.

Does my description sound like my original problem will be remedied by new struts and springs? The car just feels 'sloppy' when going over bumps and breaks in the pavement... almost to the point where it seems to 'slide sideways' (if that makes sense) if it gets unsettled enough.

It's a pretty alarming feeling to go over a bump or a joist in the concrete and feel like your car is hydroplaning (slightly) off to one side. This only happens for a split second until the car has grip again, then all is well.

I just hope that this is the fix for the problem I'm describing. Thanks again.
__________________
Thanks,
Whitney
AllCammedUp is offline   Reply With Quote
 
Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 01:54 AM.



Powered by vBulletin®. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide