The Acura Legend & Acura RL Forum - View Single Post - Legend Common Problems (Wont Start? Overheating?)
Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
View Single Post
Old 12-15-08, 10:51 PM   #22 (permalink)
Mike Diaz
Registered User
 
Join Date: Jan 2002
Location: N Canton, Ohio
Posts: 9,173


Car 1: 3.5L 1991 LS Coupe 5 Spd Blk/Blk
Car 2: 1999 Acura 3.5RL
Car 3: 2004 GMC Sierra Z71


Send a message via AIM to Mike Diaz
Quote:
Originally Posted by manslayer View Post
Car idles at 2.2k RPM all the time. When I'm driving at about 60 mph on the free way, it's up to 4.5k RPM. When I stop, it is back at 2.2K RPM and sometimes it goes up to 2.9k and drops back down to 2.2k but never lower. There are no leaks at all. What do you think?
major vacuum leak or a terribly leaky IAC or fast idle valve. If you don't know how to find this yourself, you should have somebody look at this before you prematurely wear out your transmission, mounts, etc.
Mike Diaz is offline   Reply With Quote
 
Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 06:00 PM.



acura-legend.com is an independent Acura enthusiast website owned and operated by VerticalScope Inc. Content on acura-legend.com is generated by its users. acura-legend.com is not in any way affiliated with Honda Motor Company.
Powered by vBulletin®. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
© AutoGuide