The Acura Legend & Acura RL Forum - View Single Post - Erratic Speedometer? D4 Light Flashing? Check Engine Light? HOW TO FIX! DIY
Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
View Single Post
Old 02-16-12, 11:41 PM   #44 (permalink)
Chico
Registered User
 
Chico's Avatar
 
Join Date: Jan 2011
Location: Springfield, IL
Posts: 115


Car 1: 1991 Acura Legend LS


Quote:
Originally Posted by nightevil View Post
My 93 Legend got a D4 flashing and notice that it is code 9. I have replacedm he VSS and still have the same problem. It will not flash while start the engine and will going to flash after the vehicle moved 200 meter . Can anyone tell me what to do? Speed meter normal .
i got the same problem
it occured when mechanic tried to solve my fans' problem. My fans were not turning on. He did not have enough time so we connected fans to relay then they began turning on whenever i turn the car on. Then I had CEL and D4 light on. Today replaced radiator (cuz it had some cracks on it) not CEL was gone but d4 still blinking. Speedometer is just perfect.
any ideas?
Chico is offline   Reply With Quote
 
Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:15 AM.



Powered by vBulletin®. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide