The Acura Legend & Acura RL Forum - View Single Post - Is your 91-95 Legend overheating? Got a coolant problem? Post all questions in here.
Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
View Single Post
Old 11-19-03, 09:58 PM   #9 (permalink)
legendcoupe93
 
Join Date: Jul 2003
Posts: 1,033


Quote:
Originally posted by Cole Austin
I replaced my thermostat yesterday, and I can't tell if it solved my problems yet. When I drove the car this morning the temp gauge never spiked, but the heat was still not blowing hot air consistently (sometimes blowing super hot air and other times blowing coldish air). I've had problems with air getting into the system and I have bled the air out several times.

I guess my question is if anybody has ever had problems of air in the cooling system, and non-consistent heat, did replacing the thermostat fix these problems?? Or do I have a bigger problem with my water pump/radiator/HG/heater core?
heater not blowing hot air, usualy a sign of low coolent. when u turn ur heater on it it makes the "heater controll valve" open and allow hot coolent to flow into ur dash and warm the air in the vents. having not enough coolent will cause little or no heat and air in ur system. best of luck!
drew
legendcoupe93 is offline  
 
Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 01:10 PM.



Powered by vBulletin®. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide