newbie from socal - The Acura Legend & Acura RL Forum
Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum > Welcome to Acura-Legend.com > New Member Introductions

New Member Introductions New to the site? Stop in and tell us about yourself and about your car.

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 07-17-08, 07:54 PM   #1 (permalink)
 
Join Date: Jul 2008
Posts: 5


iTrader Score: 0 reviews
newbie from socal

hey my name is Dipak and i have been on this website browsing and looking around for some help and facts. i finally decided to join. i have a 1995 acura legend coupe. green color. havent done mouch to it but lowered it, intake and exhaust. have a pioneer head unit and limo tint all around. clear corners and had a 12' kicker L7. well my older sister had this car back in the day then handed down to my youngest older sister (if that makes sence) and now it has been mine. i have been through alot with this car. alot of radiator and leaking problems. changed the radiotor, flushed the tran fluid, replaced so many hoses and still has problems. the paint is kind of oxidizing and i think the value seals are worn or broken cause the car had a rough idle and rough time accellerating. but it doesnt over heat no more. it has about 208xxx miles. well if you have any other questions just let me know. or if you have a fix for the valve seals that is cheap because im still a full time student and only 22 yo. well i hope i get alot out of this forum as others had.
speedracerd5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-17-08, 08:12 PM   #2 (permalink)
Registered User
 
91LSplendid's Avatar
 
Join Date: Oct 2007
Location: Upstate, NY
Posts: 1,665


Car 1: 1991 Legend LS Sedan
Car 2: 2008 Grand Caravan


iTrader Score: 2 reviews
Hi Dipak. Welcome. Here are cheap valve cover gaskets if that's what you are looking for. Good luck.

I purchased this set of valve cover gaskets, spark plug tube seals and grommets on ebay for less than $20 shipped. eBay Motors: 91-05 ACURA LEGEND TL RL VALVE COVER GASKET C32A C35A (item 170219176312 end time May-20-08 15:17:08 PDT)
.
__________________
John aka: Splendid

'91 LS - Golden Glow Pearl Clearcoat w/ Ivory Leather 94K miles



Mods 7 Spoke OEM Machined Rims, Sunroof Tilt, Armrest w/ Cupholder, Iggee Seat Covers w/ Controls mod. UnMods Removed tint

Gallery Pictures Link

DIY's
1) How to Install Iggee Front Seat Covers
2) Iggee front seat covers w/ seat controls mod
.
91LSplendid is offline   Reply With Quote
Old 07-17-08, 08:14 PM   #3 (permalink)
 
Join Date: Jul 2008
Posts: 5


iTrader Score: 0 reviews
hey thanks for the reply. ya i actually dont knoe what is wrong with it. but all i knoe is when i changed the spark plugs there were oil were the spark should be that why it struggles to accelerate and has rough idle
speedracerd5 is offline   Reply With Quote
 
Old 07-17-08, 08:21 PM   #4 (permalink)
Registered User
 
91LSplendid's Avatar
 
Join Date: Oct 2007
Location: Upstate, NY
Posts: 1,665


Car 1: 1991 Legend LS Sedan
Car 2: 2008 Grand Caravan


iTrader Score: 2 reviews
If it is oil on the ceramic portion of the spark plug (did you hear a squishy sound when you put your spark plug socket in to remove the spark plug? or was there oil on the coil pack?) If so then what I posted is exactly what you need. Your park plug seals went bad. Common for these older cars. You could DIY it or a shop would be about 1 hour or so labor (that's what I did).

Do a search on this forum for "valve cover" or "spark plug" and you will find many threads on the issue.
.
__________________
John aka: Splendid

'91 LS - Golden Glow Pearl Clearcoat w/ Ivory Leather 94K miles



Mods 7 Spoke OEM Machined Rims, Sunroof Tilt, Armrest w/ Cupholder, Iggee Seat Covers w/ Controls mod. UnMods Removed tint

Gallery Pictures Link

DIY's
1) How to Install Iggee Front Seat Covers
2) Iggee front seat covers w/ seat controls mod
.
91LSplendid is offline   Reply With Quote
Old 07-17-08, 08:41 PM   #5 (permalink)
Registered User
 
Join Date: Aug 2004
Location: bay area
Posts: 277


Car 1: 94 white L coupe 6spd
Car 2: GS400
Car 3: ae86


iTrader Score: 2 reviews
Send a message via AIM to toyotas4life86
i had a little oil in one of my spark plugs too but it seems to run fine
what would i notice driving wise if i had a problem with the valve cover or spark plug gasket
toyotas4life86 is offline   Reply With Quote
Old 07-17-08, 08:45 PM   #6 (permalink)
 
Join Date: Jul 2008
Posts: 5


iTrader Score: 0 reviews
ya i didnt hear any squishy noise but when i unscrew the spark plug from the socket, the thread and ceramic part is covered with oil. so is it the spark plug tube seals? i have changed a valve gasket on my old 89 accord but i knoe in this car its harder because the engine is packed in there.
speedracerd5 is offline   Reply With Quote
Old 07-17-08, 09:34 PM   #7 (permalink)
Registered User
 
91LSplendid's Avatar
 
Join Date: Oct 2007
Location: Upstate, NY
Posts: 1,665


Car 1: 1991 Legend LS Sedan
Car 2: 2008 Grand Caravan


iTrader Score: 2 reviews
If it was on the ceramic portion then yes. The oil could have got on the threads while you were removing the spark plugs (gravity) or do you think they were bathed in oil before removal...would be another problem (rings), but you would see blue smoke coming out your exhaust if this were the case.

See this thread and read from the post #9 to the end to get more info...https://www.acura-legend.com/vbulleti...8/#post1235685
.
__________________
John aka: Splendid

'91 LS - Golden Glow Pearl Clearcoat w/ Ivory Leather 94K miles



Mods 7 Spoke OEM Machined Rims, Sunroof Tilt, Armrest w/ Cupholder, Iggee Seat Covers w/ Controls mod. UnMods Removed tint

Gallery Pictures Link

DIY's
1) How to Install Iggee Front Seat Covers
2) Iggee front seat covers w/ seat controls mod
.
91LSplendid is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  The Acura Legend & Acura RL Forum > Welcome to Acura-Legend.com > New Member Introductions


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:52 PM.



Powered by vBulletin®. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide