Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
The Acura Legend & Acura RL Forum

The Acura Legend & Acura RL Forum (https://www.acura-legend.com/vbulletin/index.php)
-   First Generation RL (1996-2004) (https://www.acura-legend.com/vbulletin/forumdisplay.php?f=29)
-   -   Balance shaft belt broke, am i screwed? (https://www.acura-legend.com/vbulletin/showthread.php?t=164890)

Justiss27 02-25-19 01:01 AM

Balance shaft belt broke, am i screwed?
 
1 Attachment(s)
Okay so got a question. This is the first time im tackling this kind of issue. Iv always tried to stay away from anything that delt with timing but this one has a lot of personal meaning to me so i wanted to dig into it. 96 Acura 3.5RL, I thought i just had a bad water pump but juat popped the cover off and surprise..broken belt..everything I know about this problem is when timing belt goes 90% chance the engins toasted...but the timing belt isnt what broke..? Am I still pretty much SOL or is their a chance I can save it...


All times are GMT -4. The time now is 08:22 AM.

Powered by vBulletin®. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 08:22 AM.



Powered by vBulletin®. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide