Things wrong with your 1996-2004 Acura RL - Page 2 - The Acura Legend & Acura RL Forum
Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum > Acura RL > First Generation RL (1996-2004)

First Generation RL (1996-2004)

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 06-29-08, 03:47 AM   #16 (permalink)
Super Moderator
 
J Witherspoon's Avatar
 
Join Date: Feb 2004
Location: Charlotte, NC
Posts: 3,374


Car 1: 2004 Acura 3.5RL
Car 2: 2005 Chevy Tahoe z71


iTrader Score: 0 reviews
Send a message via AIM to J Witherspoon
Quote:
Originally Posted by seamusNH View Post
I never had any problems with the steering wheel audio control. For my 96 RL (base model) the part is 35880-SP0-003; list is 91.73; acuraoemparts.com has it for 73.38. It fits 96 - 98. I have the part if anyone needs one. (I parted out the RL).
hnic - what is the problem with the speakers? The stereo in my RL always seemed underpowered, but there were no real problems with it.
RaiC - the flaking "chrome" on the door handle is common in older RLs. RLs in the US have the CD changer in the trunk; while in other countries, it is in the console.
I'll have to check my stereo and speakers when I get home. I thought it was Bose...
my speakers are done for. I think they're blown...and they should be being 10 yrs old and all.
J Witherspoon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-30-08, 11:18 AM   #17 (permalink)
Registered User
 
seamusNH's Avatar
 
Join Date: Apr 2008
Location: New Hampshire, USA
Posts: 245


Car 1: 96 Acura RL


iTrader Score: 0 reviews
hhnic, you can probably get some new aftermarket speakers less expensively than from an acura dealer. If you want the ones from my old RL, I can sell them for $15 each plus shipping. My car is a 96 RL so at least you know they will fit.... [email protected] if you are interested...
seamusNH is offline   Reply With Quote
Old 07-04-08, 08:24 AM   #18 (permalink)
Registered User
 
dynamite's Avatar
 
Join Date: Nov 2005
Location: Sydney
Posts: 39


Car 1: 2000 C35A3


iTrader Score: 0 reviews
Send a message via MSN to dynamite
SRS light stays on due to faulty driver side belt buckle, thats it.
dynamite is offline   Reply With Quote
 
Old 07-04-08, 01:38 PM   #19 (permalink)
5.9K all day
 
Spade's Avatar
 
Join Date: Oct 2007
Location: Weston, Florida
Posts: 60


Car 1: 1997 RL
Car 2: 2005 RSX-S


iTrader Score: 0 reviews
wow some of you guys have a bunch of problems with your car!

my AC dont work, belt is gone.
thats it. oh and the sunglasses compartment broke within a year when it was still my moms car.
__________________
Vtec
Spade is offline   Reply With Quote
Old 07-04-08, 02:02 PM   #20 (permalink)
Registered User
 
chapman89's Avatar
 
Join Date: Feb 2006
Location: Charlotte, NC
Posts: 1,803


Car 1: 1993 Acura Legend LS


iTrader Score: 9 reviews
Send a message via AIM to chapman89
I just had my axle replaced and new boots installed on the bellows unit.

only one issue now! Crappy weather stripping!
chapman89 is offline   Reply With Quote
Old 07-16-08, 05:46 PM   #21 (permalink)
Registered User
 
seamusNH's Avatar
 
Join Date: Apr 2008
Location: New Hampshire, USA
Posts: 245


Car 1: 96 Acura RL


iTrader Score: 0 reviews
Spade - replacing the belt is not too bad as long as you can get the alternator belt off. When I tried to fix mine, I found that the small pulley wheel was broken and the shaft that it is on was bent. Too much damage to fix....
seamusNH is offline   Reply With Quote
Old 07-16-08, 07:02 PM   #22 (permalink)
Registered User
 
Join Date: Jul 2008
Posts: 2,403


iTrader Score: 12 reviews
Things wrong with my '91 Legend LS
1. No A/C
2. Steering wheel audio controls
3. no ABS - fine with me
That's it... the car does need
1. new muffler
2. new tires
LegendLand is offline   Reply With Quote
Old 07-16-08, 08:35 PM   #23 (permalink)
Renaissance.
 
whats77inaname's Avatar
 
Join Date: Jul 2005
Location: Tx
Posts: 3,001


Car 1: 91 5MT LS, 310k
Car 2: 91 5MT LS, 208k
Car 3: 03 G35 sdn (wife's)


iTrader Score: 33 reviews
Quote:
Originally Posted by LegendLand92 View Post
Things wrong with my '91 Legend LS
Thread title:

Things wrong with your 1996-2004 Acura RL
whats77inaname is offline   Reply With Quote
Old 07-16-08, 08:46 PM   #24 (permalink)
Registered User
 
Join Date: Jul 2008
Posts: 2,403


iTrader Score: 12 reviews
Quote:
Originally Posted by whats77inaname View Post
Thread title:

Things wrong with your 1996-2004 Acura RL
So what, Other people said things about their legends What's the problem???? I KNOW THE TITLE!

Plus, posting here helps with my post count! CHA-CHING!
LegendLand is offline   Reply With Quote
Old 07-17-08, 12:09 AM   #25 (permalink)
Find Em Fuck Em Forget Em
 
GrumpySteelMan's Avatar
 
Join Date: Oct 2007
Location: Greensboro, NC
Posts: 922


Car 1: 2004 Nighthawk RL
Car 2: 2005 Nighthawk TL
Car 3: 2002 525i Sport Wag


iTrader Score: 0 reviews
Send a message via AIM to GrumpySteelMan
Quote:
Originally Posted by hnic View Post
1.) Steering wheel audio controls
Dammit, I have to get this fixed. It makes me nuts.
__________________
"A gentleman is one who never hurts anyone's feelings unintentionally." -Oscar Wilde
3.5RL With/Without Nitrous Comparo Video
GrumpySteelMan is offline   Reply With Quote
Old 07-17-08, 09:12 AM   #26 (permalink)
Renaissance.
 
whats77inaname's Avatar
 
Join Date: Jul 2005
Location: Tx
Posts: 3,001


Car 1: 91 5MT LS, 310k
Car 2: 91 5MT LS, 208k
Car 3: 03 G35 sdn (wife's)


iTrader Score: 33 reviews
Quote:
Originally Posted by LegendLand92 View Post
So what, Other people said things about their legends What's the problem???? I KNOW THE TITLE!

Plus, posting here helps with my post count! CHA-CHING!
And I suppose if other people were jumping off a cliff.....

On a side note, however, I do like your Avatar....
whats77inaname is offline   Reply With Quote
Old 07-17-08, 12:59 PM   #27 (permalink)
Registered User
 
Join Date: Jul 2008
Posts: 2,403


iTrader Score: 12 reviews
Quote:
Originally Posted by whats77inaname View Post
And I suppose if other people were jumping off a cliff.....

On a side note, however, I do like your Avatar....
I don't get what you're trying to say in the first part there... but, Thanks for the comment on the avatar!
LegendLand is offline   Reply With Quote
Old 07-18-08, 08:57 PM   #28 (permalink)
Super Moderator
 
J Witherspoon's Avatar
 
Join Date: Feb 2004
Location: Charlotte, NC
Posts: 3,374


Car 1: 2004 Acura 3.5RL
Car 2: 2005 Chevy Tahoe z71


iTrader Score: 0 reviews
Send a message via AIM to J Witherspoon
Transmission is acting up. please see my thread.
J Witherspoon is offline   Reply With Quote
Old 07-18-08, 11:54 PM   #29 (permalink)
Registered User
 
Join Date: Feb 2008
Location: Houston
Posts: 32


iTrader Score: 0 reviews
just last night my rear left break line busted on me while on the freeway going bout 100+ (cuz im an idiot) The Rl Loves it lol. I was like thats funny my break pedal feels a lil diff. I pressed it more and more and nothing ahhhhh. ill i can do is let go of the gas lol. My breaks worked somewhat but very sloppy. Got home looked at the underside and wow breakfluid all under the car and all over my left wheel.
unorthodoxkustoms is offline   Reply With Quote
Old 07-19-08, 11:28 AM   #30 (permalink)
Registered User
 
seamusNH's Avatar
 
Join Date: Apr 2008
Location: New Hampshire, USA
Posts: 245


Car 1: 96 Acura RL


iTrader Score: 0 reviews
Quote:
Originally Posted by unorthodoxkustoms View Post
just last night my rear left break line busted on me while on the freeway going bout 100+ (cuz im an idiot) The Rl Loves it lol. I was like thats funny my break pedal feels a lil diff. I pressed it more and more and nothing ahhhhh. ill i can do is let go of the gas lol. My breaks worked somewhat but very sloppy. Got home looked at the underside and wow breakfluid all under the car and all over my left wheel.
Yikes! Relatively speaking you lucked out. It could have been a serious accident in other circumstances...
seamusNH is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  The Acura Legend & Acura RL Forum > Acura RL > First Generation RL (1996-2004)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 05:58 PM.



Powered by vBulletin®. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide