Things wrong with your 1996-2004 Acura RL - Page 5 - The Acura Legend & Acura RL Forum
Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum > Acura RL > First Generation RL (1996-2004)

First Generation RL (1996-2004)

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 10-29-09, 09:55 PM   #61 (permalink)
Registered User
 
Join Date: Oct 2009
Location: San Jose
Posts: 1


Car 1: 1996 RL


iTrader Score: 0 reviews
Radio does not power up
Front dome lights dont work
Cig lighter does not work

Any help on the elctrical would be great
I check all the fuses already on the driver side kick panel

and the ABS unit needs to be replaced

Max
Max_Misawa is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-29-09, 10:59 PM   #62 (permalink)
Registered User
 
seamusNH's Avatar
 
Join Date: Apr 2008
Location: New Hampshire, USA
Posts: 245


Car 1: 96 Acura RL


iTrader Score: 0 reviews
Go to Download PDF PDFTown.com | Free Download PDF and eBook and search on "Acura RL". Download the manual. that will help you get started. There are fuses under the hood.

I have some parts from my old RL. The stock stereo worked fine. $75 plus shipping. I have the ABS components. That is a complicated system so go thru the troubleshooting in the manual to determine the problem.

Contact me at [email protected] if you need parts...
seamusNH is offline   Reply With Quote
Old 10-30-09, 01:52 AM   #63 (permalink)
Registered User
 
Join Date: Oct 2009
Location: Maryland
Posts: 26


Car 1: 2003 Nissan Maxima


iTrader Score: 0 reviews
cars are predictable. parts break all the time, yet we always buy new parts to replace them. sorta like a chick!
Teaner is offline   Reply With Quote
 
Old 12-31-09, 06:02 PM   #64 (permalink)
Registered User
 
Join Date: Dec 2009
Location: San diego
Posts: 1


Car 1: M3


iTrader Score: 0 reviews
Very helpful thread, thanks
mike2009yahoo is offline   Reply With Quote
Old 01-13-10, 11:17 PM   #65 (permalink)
Registered User
 
Georgio103's Avatar
 
Join Date: Jan 2010
Location: Broken Arrow, Ok.
Posts: 4


Car 1: 98' Acura Special Edition RL


iTrader Score: 0 reviews
Send a message via Yahoo to Georgio103
Have a 98' Acura Special Edition RL with only 105k miles..
the only problem i have on it currently is:
Steering wheel does not move up or down.
Rear suspension broke...O'reilly told me i had to get either salvage or dealer.
(dealer said its around 300 for just the springs, damn)
Georgio103 is offline   Reply With Quote
Old 08-31-10, 07:25 AM   #66 (permalink)
Registered User
 
Join Date: Jan 2010
Location: NYC
Posts: 10


iTrader Score: 0 reviews
My 97 RL
-A/C compressor shot, no belt, no A/C I've seen what seems like a lot people's RLs with this prob. My friends 98 RL, same thing.
-Rear view mirror broken.

My 02 RL
-One rear window doesn't come down. Might be off the track. I hear the motor run when I push down/pull up the control. Seems like a lot people have window problems in their RLs. Gotta be a design defect Acura.

So far everything else is good. "Knock on wood"
beta5237 is offline   Reply With Quote
Old 09-04-10, 11:59 AM   #67 (permalink)
Registered User
 
Join Date: Dec 2009
Location: Piscataway NJ
Posts: 12


Car 1: 2000 Acura RL


iTrader Score: 0 reviews
Things wrong with my 2000 RL:
1) Front sway bars broken, had them replaced for $100
2) Corrosion in the shield fitted along the muffler
3) ABS,VSA lights came on (sometime they go off, but most times on)
4) Radiator had a leak, replaced it myself - cost non-oem part $75
5) Screeching noise from brake pads
acurarl2000 is offline   Reply With Quote
Old 09-12-10, 12:48 PM   #68 (permalink)
Registered User
 
Join Date: Aug 2010
Location: CenCal
Posts: 34


Car 1: 1996 RL


iTrader Score: 0 reviews
driver side outer cv boot is busted, two lower rear control arms are bent, radiator is leaking.
Japam is offline   Reply With Quote
Old 06-02-11, 08:34 AM   #69 (permalink)
Registered User
 
Join Date: May 2011
Location: Eastern PA
Posts: 8


Car 1: 1996 Acura RL Base
Car 2: 1995 Volvo 850 Wagon
Car 3: 1994 Land Cruiser


iTrader Score: 0 reviews
Just got my 1996 RL with 148k and don't have a single problem on it except the pesky Main Relay is shot now and ordered a new one.

But I also have detailed maintenance records from 44k miles. They did the radiator because of a leak and also a few window regulators a while ago along with timing belt etc so that might explain my lack of problems
timer00 is offline   Reply With Quote
Old 07-03-11, 07:38 PM   #70 (permalink)
Registered User
 
Join Date: Oct 2005
Location: LA
Posts: 12


Car 1: 2002 RL Silver/Black STOCK!


iTrader Score: 0 reviews
02 RL, just changed out my 'speed sensor' (what the mechanic told me) because I noticed my speed guage was sputtering all over the place. Also had the Engine, (!), and VSA lights come on, including the D4 light which was flashing. Looked pretty serious, but the car was running just fine mechanically, so I drove it around like that until I got it fixed.

Got the part ($125) switched out and everything was fine. About a month later, same thing. I'm guessing it's a bad sensor and I just need it replaced, but my main question is................

Q1: Can I keep driving my car with the check engine light on. Mechanically everything is perfect, but I don't know if the computer will shut me down if I continue for so many miles, etc.

Q2: Anyone have any computer issues with their 02, 03, 04 RL's?
hnoori76 is offline   Reply With Quote
Old 07-15-11, 02:00 PM   #71 (permalink)
Registered User
 
Brownman_'s Avatar
 
Join Date: Mar 2011
Location: Washington State
Posts: 6


Car 1: 98 RL
Car 2: 96 Legacy L


iTrader Score: 0 reviews
Things that are fucked up on my 1998 RL/Legend

1. Day Lights
2. Coolant Cluster Blulb
3. Radiator Cap
4. SRS Light
Brownman_ is offline   Reply With Quote
Old 08-29-11, 11:20 PM   #72 (permalink)
Registered User
 
Join Date: Aug 2011
Location: United Kingdom
Posts: 5


Car 1: 1998 Honda Legend
Car 2: 1999 Accord Type-R


iTrader Score: 0 reviews
Issues I have discovered so far with mine are

a couple of dash bulbs not working
2 rust spots on nsr arch
scuffs on bumpers on all corners where previous owner didn't know how long the car is lol
steering wheel doesn't raise or lower
cracked tail light

hoping this list stays short
Joe_Blob is offline   Reply With Quote
Old 10-27-11, 03:18 PM   #73 (permalink)
Registered User
 
Join Date: Oct 2011
Location: longisland
Posts: 12


Car 1: 02 acura cl
Car 2: 98 acura rl


iTrader Score: 0 reviews
my 98 rl idles rough when warm, i heard this could have something to do with an ecu sensor, also i was wondering if i could put a 99 front bumper on my 98? im looking for some diy mods i bought the car on craigslist and got ripped off to say the least, im just trying to make the best out of a bad situation so any help is appreciated! thanks!!!!!
wyte3.5RL is offline   Reply With Quote
Old 10-27-11, 04:01 PM   #74 (permalink)
Fut RIP
 
L3GDKANG/JDMKANG's Avatar
 
Join Date: Apr 2006
Location: 10-A-KEY
Posts: 10,147


Car 1: 91 Alpha/Alpha Touring KA7
Car 2: 92 Alpha/ AlphaT KA8
Car 3: 91L,93LS,94LS KA7's


iTrader Score: 39 reviews
Quote:
Originally Posted by wyte3.5RL View Post
my 98 rl idles rough when warm, i heard this could have something to do with an ecu sensor, also i was wondering if i could put a 99 front bumper on my 98? im looking for some diy mods i bought the car on craigslist and got ripped off to say the least, im just trying to make the best out of a bad situation so any help is appreciated! thanks!!!!!
yes you can put a newer bumper on your car look up after math on here it has to be 1 of the best ka9's on the planet
__________________

Yes im back! Alpha/AlphaTouring!https://www.acura-legend.com/vbulleti...ang%2Fjdm-kang
Originally Posted by Blackend
Good to meet you too Willie. I tell ya, when we were walking the Auto-X course and you guys started pulling in, I had no idea who it was until I saw the green machine and we're all like "ooohhhh, that's Willie and the Acuraholicks!"

Glad you guys made it out, and nice meeting all of you.
L3GDKANG/JDMKANG is offline   Reply With Quote
Old 10-28-11, 02:07 PM   #75 (permalink)
Registered User
 
Join Date: Oct 2011
Location: longisland
Posts: 12


Car 1: 02 acura cl
Car 2: 98 acura rl


iTrader Score: 0 reviews
98 acura rl - as of right now-

1- idle fluctuates when at running temp
2-no heat, only blows cold air
3-srs light stays on
4-takeing on water threw the sun roof , water is pooling in headliner.

thats just to start if any one can help me i would greatly appreciate it!
wyte3.5RL is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  The Acura Legend & Acura RL Forum > Acura RL > First Generation RL (1996-2004)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 12:40 PM.



Powered by vBulletin®. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide